Returnera sista värdet i en kolumn

Leif skriver in mängder av tal i olika kolumner i ett stort kalkylblad. Överst i kalkylen vill han se de sista/senaste värdena i kolumnerna han matat in, från exempelvis rad 1 000. Skriver han in nya tal på rad 1 001, eller rad 1 005 ska talet/värdet i den sista cellen visas överst i kalkylbladet. Bilden illustrerar inskrivna tal i cellerna A1 till A6.

Formeln i cell C3 är: =INDEX(A:A; ANTAL(A:A))

 

Den här formeln fungerar endast om värdena är numeriska. Uppstår det tomma celler, celler med 0 (noll) eller celler med text finns det en annan lösning.

I cell B1 finns formeln =OM(ÄRTAL(A1); OM(A1<>0;RAD(A1);””);””)

Den returnerar radnumret i de celler som har ett numeriskt värde. Men ignorerar ett radnummer i de celler som är tomma eller innehåller värdet 0 (noll) eller innehåller text. Denna lösning gör det möjligt att returnera det sista talet i kolumn A med följande formel.

I Cell C3 finns följande formel: =INDEX (A:A;MAX(B:B))

 

 

Formeln returnerar det högsta radnumret i kolumn B och hämtar motsvarande värde i kolumn A med hjälp av funktionen Index.

This entry was posted in Excel and tagged , , . Bookmark the permalink.

2 Responses to Returnera sista värdet i en kolumn

  1. Emelie says:

    Om det inte ät tal i kolumnen utan text, t.ex namn. Vad kan jag använda för formel då för att kunna visa vilket namn som är inskrivet längst ner/sist i kolumnen?

    • admin says:

      Hej Emelie,

      Du byter ut ANTAL till ANTALV i formeln. Formeln i cell C3 blir då =INDEX(A:A;ANTALV(A:A))
      Se nytt inlägg på bloggen.

      MVH,
      Bengt Danebring

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *