Extrahera data med dropdown-list

I bilden nedan finns en lista med data i kolumnerna A till C. Detta inlägg kommer att visa hur du skapar en dropdown-list i cell H2 för att extrahera data om respektive land. Resultatet kommer då att visas i kolumnerna J till L. Du kan göra samma sak betydligt snabbare med en pivottabell, men jag vill här visa hur man på ett fiffigt sätt arbetar med hjälpkolumner i Excel och sedan använder Excels kraftfulla funktioner för att få ett önskat resultat.

Extrahera data med dropdown list

Först markerar och kopierar du C kolumnen och klistrar in länderna i valfri kolumn t.ex. kolumn O. Du ska här ta bort dubbletterna som finns i listan. Välj fliken Data, Ta bort dubbletter. Listan består nu av unika länder. Placera markören i cell H2 och välj sedan Dataverifiering under fliken Data.

Extrahera data med dropdown list-2

 

Under Tillåt väljer du Lista. Klicka sedan in i fältet Källa och markera in de unika länderna, här i cellerna O2 till O9. Du har nu skapat en dropdown-list i cell H2.

 

Extrahera data med dropdown list-3

 

I nästa steg skapar du en hjälpkolumn med serienummer indexnummer för alla posterna. Se kolumn D Hjälpkolumn 1.

Cell E2 i Hjälpkolumn 2 innehåller följande formel: =OM(C2=$H$2;D2;””) vilket innebär att om t.ex. Indien väljs i dropdown-listen visas motsvarande siffra från kolumn D. Se bilden bredvid.

I hjälpkolumn 3 cell F2 finns följande formel =OMFEL(MINSTA($E$2:$E$26;D2);””). Omfel utför en felkontroll och funktionen Minsta returnerar det n:te minsta värdet i en datamängd, här i kolumn E.

 

Hjälpkolumnerna är nu klara och kan med fördel döljas. Slutligen väljer du var du vill placera din extraherade data. I bilden nedan placeras den med början i cell J2 och formeln är: =OMFEL(INDEX($A$2:$C$26;$F2;KOLUMNER($J$1:J1));””)

Extrahera data med dropdown list-4

Funktionen Index extraherar data utifrån radnumret $F2. Kolumner returnerar antal kolumner i ett cellområde och funktionen Omfel returnerar inget om det inte finns någon data.

 

This entry was posted in Excel and tagged , , . Bookmark the permalink.

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *