Dynamiska förklaringsetiketter i linjediagram

När du skapar ett standardlinjediagram i Excel kan det bli knepigt och tidsödande att tolka linjerna om du har mer än två serier i ditt linjediagram. Presenterar du denna typ av diagram till en publik eller till dina medarbetare gör du dem en otjänst. Tyvärr ser jag det också ofta i olika publikationer och dagstidningar. Se t.ex. på diagrammet i bilden nedan.

Dynamisk förklaringstext i linjediagram

 

Ögat måste hela tiden pendla mellan linjerna och förklaringstexten nederst i diagrammet.

 

Dynamisk förklaringstext i linjediagram-2

 

Du kan förbättra diagrammet genom att lägga förklaringsetiketterna till höger. Markera förklaringsrutan, högerklicka och välj Formatera förklaring. Men trots det kan det bli svårt att avläsa om du har fem, sex eller fler serier.

Tänk om det fanns ett sätt i Excel att placera förklaringsetiketten till höger om linjen och att den även förflyttar sig allteftersom du uppdaterar och skriver in nya data. Som ofta i Excel kan du lösa detta genom att skriva en smart formel. Kolla in bilden nedan.

Dynamisk förklaringstext i linjediagram-3

 

Se först till att du har all data in en tabell. I linjediagrammet vill vi visa utfallet i förhållande till budget under ett antal månader, och detta representeras av kolumnerna A till D.

Kolumnerna E och F kommer att visa förklaringsetiketten dynamiskt, dvs. den kommer att förflytta sig när nya data skrivs in i kolumn D.

 

 

Den eleganta formeln i cell E2 är följande: =OM(OCH(C3=””;C2<>””);[@Budget];SAKNAS())

Två villkor måste uppfyllas i den logiska testen. Först måste C3 vara tom och sedan måste C2 inte vara tom för att formeln ska returnera Sant. I annat fall returneras #SAKNAS!
I bilden ses resultatet tydligast i cell F11. [@Budget] är en strukturerad cellreferens eftersom det är en tabell. Den kommer per automatik när du klickar in cell C1 när du skriver formeln.

Formeln i cell F2 blir följande när du kopierat den från cell E2. =OM(OCH(D3=””;D2<>””);[@Utfall];SAKNAS())

Dynamisk förklaringstext i linjediagram-4

 

Infogar du nu ett linjediagram utifrån tabellen och placerar förklaringsrutan till höger, ser det ut som bilden visar.

 

Nu återstår det finurliga och trixiga att få budget- och utfallsetiketterna att visas till höger om linjerna. Markera hela diagramytan och högst upp under Diagramverktyg finns fliken Format.

Dynamisk förklaringstext i linjediagram-5

 

Längst till vänster finns en dropdown-list och här väljer du Serie ”Budget 2”. Nu markeras kolumn E.

 

 

 

 

Välj sedan plustecknet som visar Diagramelement och lägg muspekaren över Dataetiketter som ger dig möjlighet att välja Höger. Bra alternativ är även Över och Under och nu visas talet 260 till höger om budgetlinjen.

Dynamisk förklaringstext i linjediagram-6

 

Gör sedan på samma sätt med Serie ”Utfall 2” och skriver du nu in nya data i utfallskolumn D expanderar linjen med förklaringsetiketten.

Dynamisk förklaringstext i linjediagram-7

 

This entry was posted in Excel, Office 365 and tagged , , , . Bookmark the permalink.

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *