Villkorsstyrd formatering – nytt exempel

Att använda villkorsstyrd formatering är populärt bland många Excelanvändare. Inte så konstigt då man kan få olika visuella attribut i celler för att fånga ens uppmärksamhet.

Jonas vill t.ex. att cell D4 ska bli gul om värdet i cell B4 är större eller lika med värdet i cell D1. Att enbart använda villkorsstyrd formatering i detta fall går inte, om man inte först kombinerar det med en Om formel. Se bilden nedan.

Villkorsstyrd formatering - nytt exempel

I cell D4 finns formeln =OM(B4>=D1;SANT;””)

Om villkoret uppfylls returneras SANT i cell D4, vilket kan användas i villkorsstyrd formatering. Är B4 mindre än 10 visas ingenting.

Sedan markerar Johan cell D4 och väljer Start, Villkorsstyrd formatering, Ny regel och Formatera endast celler som innehåller.

Villkorsstyrd formatering - nytt exempel-2

Nederst i dialogen väljer han Specifik text innehåller Sant och så formaterar han cellen gul.

Om han inte vill se texten SANT kan han formatera teckenfärgen med samma gula färg som cellens fyllningsfärg.

 

This entry was posted in Excel and tagged , , . Bookmark the permalink.

2 Responses to Villkorsstyrd formatering – nytt exempel

  1. Roger Nilsson says:

    Hej, jag är också ute efter Villkorsstyrd formatering, men skillnaden är att jag vill färgmarkera tomma fält.
    Jag har dagarna i en månad längst upp, 1, 2, 3, 4, 5…31 i rutorna B1 -> AF1
    Sedan har jag veckodagarna mån, tis, ons… under i B2 -> AF2

    Sedan har jag i A2, A3, A4, A5 olika namn (Kalle, Pelle, Olle, Nisse)

    Jag vill markera ut vilka dagar som är lördag och söndag med en grå bakgrund, d.v.s då jobbar vi inte.
    Skillnaden här mot dina två tidigare exempel är att du färgmarkerar där du står.
    Nu vill jag färgmarkera andra fält. Om jag ändrar vilken månad det är, då kommer veckodagarna att flyttas, så jag kan inte ha formler i dom fälten.
    Det betyder att i G2 står Lör och då vill jag gråmarkera G3:G6

    • admin says:

      Hej Roger,
      Jag har kikat på ditt exempel och anser att det är lättare för dig att markera alla kolumner som har lördagar och söndagar. Du kan färglägga alla celler grått genom att först göra en splittrad markering med Ctrl-tangenten. Men du får gärna förtydliga lite om jag missuppfattad det du skriver.
      Mvh

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *